PR
TIPS

How to resolve UnicodeDecodeError in Certbot

If you are using Certbot and encounter an error like the following

UnicodeDecodeError: 'ascii' codec can't decode byte 0xe3 in position 12: ordinal not in range(128)

This may occur because the nginx configuration file (conf file) contains non-ASCII characters (e.g., Japanese).

To solve this problem, remove the Japanese characters in the nginx conf file or convert them to English. This will allow Certbot to work properly.

Comment

Copied title and URL